Atualmente, o Python é uma das linguagens de programação mais populares. Isso graças à sua facilidade de uso e suporte a bibliotecas externas. Por isso, a Microsoft cogita adicionar suporte à linguagem Python no Excel.

Python no Excel – Sugestão do público!

Na Central de Feedback da Microsoft, a sugestão com mais votos para Excel pede ”permita-nos fazer scripts com Python… não só como uma alternativa ao VBA, mas também como uma alternativa a funções como (=SOMA(A1:A2))”.

Essa ideia é antiga, foi publicada por um usuário em novembro de 2015. Ashvini Sharma, gerente de programa do Excel, respondeu na época: ”nós vamos investigar isso para uma atualização futura”. A ideia ficou parada até que, em outubro do ano passado, Sharma afirmou: ”estamos ocupados construindo uma infraestrutura que permite a execução remota de código arbitrário a partir de funções personalizadas no Excel”. É um sinal de que o projeto está andando, mesmo que lentamente.

Atualizações

A atualização mais recente, também de Sharma, pede que os interessados na integração entre Python e Excel respondam a um questionário. No caso desse suporte ser confirmado, os usuários poderiam usar os scripts do Python para interagir com os documentos, dados e funções do Excel, semelhante ao que é possível atualmente com os scripts VBA. O Visual Basic for Applications é uma linguagem de programação que pode ser usada dentro do pacote Microsoft Office, incluindo Word, Excel e PowerPoint. O desafio será implementar Python em todos esses programas, além do Excel.

”É importante que isso seja consistente em toda a experiência do Office. Alguns de nós somos velhos o suficiente para lembrar das múltiplas versões do VB-alguma coisa para o Excel, Word, Access, que eram um golpe para a produtividade”, disse um usuário sobre esse assunto no Hacker News. Sim, eles devem escolher o Python e, no processo, decidir se será o Python com uma biblioteca.Net (padrão e núcleo como libs separadas, por favoe!) ou IronPython. Isso em si é uma importante primeira escolha. Então, isso tem que ser feito em um mecanismo que permita exatamente as mesmas libs e códigos Python escritos pelo usuário funcionem da mesma maneira em todos os produtos do Office”, acrescentou outro usuário.

E você, o que acha do tema? Comente com a gente!

Deixe um comentário ou uma dúvida